Search found 8 matches

by SalPal
Thu Mar 14, 2019 2:27 am
Forum: minisatip
Topic: Autostart: proper way on headless system...
Replies: 3
Views: 255

Re: Autostart: proper way on headless system...

I might found the problem: After looking at process list (# ps -aux) I found that my playlist in startup option was truncated after ".", there was no "...m3u" at the end. Guessing that whole string was not parsed properly I did include double quotes around URL for play list. After reboot it happily ...
by SalPal
Thu Mar 14, 2019 1:40 am
Forum: minisatip
Topic: Autostart: proper way on headless system...
Replies: 3
Views: 255

Re: Autostart: proper way on headless system...

9000h, all, " Armbian/Interface" I assume is network? My network is on Auto and I see no problem with it: source /etc/network/interfaces.d/* _____________________________ # Network is managed by Network manager auto lo iface lo inet loopback ______________________________ And to clarify: everything ...
by SalPal
Wed Mar 13, 2019 2:26 am
Forum: minisatip
Topic: Autostart: proper way on headless system...
Replies: 3
Views: 255

Autostart: proper way on headless system...

I'm running it very smoothly on OPiZ with Armbian and Hauppauge 950Q. That is with manual start, everything works as it should and all devices see it as SAT>IP. Great! Now I'm attempting to setup auto-start: in /etc/rc.local _______________ sleep 5 cd /minisatip sudo ./minisatip -p http://x.x.x.x/pl...
by SalPal
Sat Feb 23, 2019 2:36 pm
Forum: minisatip
Topic: ATSC use?
Replies: 8
Views: 381

Re: ATSC use?

Updates: After some testing it appeared that bandwidth and modulation settings are optional. In source code they default to auto. In reality this may cause request to hang indefinitely (~1 of 4 calls) or more often delaying start of streaming by 5-6 seconds (this is probably why I initially missed i...
by SalPal
Sat Feb 23, 2019 2:56 am
Forum: minisatip
Topic: ATSC use?
Replies: 8
Views: 381

Re: ATSC use?

I can't believe it but I did figure it out: ....?bw=6.000000&msys=atsc&mtype=256qam&freq=213&pids=65,68 .........edit your own frequency and PIDs It took me digging through source code to figure out right switches. So QAM256 must be written as "256qam". ATSC-C QAM (256) confirmed working! :-) Cheers...
by SalPal
Sat Feb 23, 2019 2:26 am
Forum: minisatip
Topic: ATSC use?
Replies: 8
Views: 381

Re: ATSC use?

9000h, Thanks for the hint! As I understand your excerpt is from Hauppage device? I'm not sure what to do with "wait" and other options: "dab" and "cmmb". So new URL will be: ...?bw=6&msys=atsc&mtype=qam256&freq=213&pids=65,68 It appeared that modulation type not parsed and not used in processing. S...
by SalPal
Fri Feb 22, 2019 3:57 am
Forum: minisatip
Topic: ATSC use?
Replies: 8
Views: 381

Re: ATSC use?

After long nights I was able to successfully tune with w_scan and tvheadend works, so system is confirmed. Interestingly, in tvheadend it appeared as two independent inputs with every single parameter identical, including: frontend0, dvr0, demux0 and device path. The only difference is the names: "...
by SalPal
Fri Feb 01, 2019 1:23 am
Forum: minisatip
Topic: ATSC use?
Replies: 8
Views: 381

ATSC use?

Can anybody please help with ATSC examples? Somehow there is none anywhere I look. :(
Specifically separately for QAM and VSB ( equivalent to DVB's T and C).

Thanks!