MCD / MTD support using DD hardware

Support forum for minisatip
c-o-m-m-a-n-d-e-r
Posts: 2
Joined: Mon Aug 14, 2017 12:55 pm

Re: MCD / MTD support using DD hardware

Post by c-o-m-m-a-n-d-e-r » Tue Sep 05, 2017 4:06 pm

any news here?

yellowstorm
Posts: 2
Joined: Tue Jul 25, 2017 8:41 pm

Re: MCD / MTD support using DD hardware

Post by yellowstorm » Fri Oct 20, 2017 4:42 pm

It would be very nice... I also use DD hardware!
Maybe we get a christmas present?

carter
Posts: 11
Joined: Fri Jun 30, 2017 10:54 am

Re: MCD / MTD support using DD hardware

Post by carter » Sat Jun 02, 2018 11:49 pm

Just want to ask for the latest news/update about DDCI hardware?

Is there something ready to test, I've seen DDCI=0 and DDCI_TEST=0 in the makefile.

I did already some tests with several combinations, but without any success.
Are there special settings/configurations to do, for getting anything running with DDCI hardware?

Would be nice, to get some infos about it...

Thank you - Carter

cata
Site Admin
Posts: 436
Joined: Tue May 12, 2015 1:01 am

Re: MCD / MTD support using DD hardware

Post by cata » Sun Jun 03, 2018 5:40 am

I am still testing, but basically if you have the hardware DDCI=1 and DDCI_TEST=0.

carter
Posts: 11
Joined: Fri Jun 30, 2017 10:54 am

Re: MCD / MTD support using DD hardware

Post by carter » Sun Jun 03, 2018 9:14 am

Currently I'm using a DD-CineS2 V6.5 with a connected Octopus flex CI (via bus cable).

Linux recognises /dev/dvb/adapter[0...3] with S2 adapter devices in /dev/dvb/adapter[0,1]/..., and ca0 and ci0 in each /dev/dvb/adapter[2,3]/...

In adapter /dev/dvb/adapter2/ is a ACL2.2 plugged in.

After starting, I only get messages like these:

Code: Select all

[03/06 10:37:16.449 AD0]: Starting select_and_execute on thread ID f1482700, thread_name AD0
[03/06 10:37:16.449 main]: No CA device detected on adapter 0: file /dev/dvb/adapter0/ca0
[03/06 10:37:16.461 AD1]: Starting select_and_execute on thread ID f0c81700, thread_name AD1
[03/06 10:37:16.461 main]: No CA device detected on adapter 1: file /dev/dvb/adapter1/ca0
I have two interfaces in /dev/dvb/adapter2/ca0 and ci0 and /dev/dvb/adapter3/ca0 and ci0

My CAM is connected to adapter2

No log entry occurs from them...

(FYI, my smartdcard/CI/CAM are working together on the same machine/OS, when running vdr and DDCI2 plugin)

--> Which Digital Devices driver version / kernel combination are you using?

UPDATE:

I'm using kernel 4.8.0-53 and the latest device drivers from DD Release-0.9.33

cata
Site Admin
Posts: 436
Joined: Tue May 12, 2015 1:01 am

Re: MCD / MTD support using DD hardware

Post by cata » Sun Jun 03, 2018 3:37 pm

Can you upload the entire log?

carter
Posts: 11
Joined: Fri Jun 30, 2017 10:54 am

Re: MCD / MTD support using DD hardware

Post by carter » Sun Jun 03, 2018 4:49 pm

--> starting minisatip with this command:

Code: Select all

./minisatip -t -x 8016 --document-root /usr/share/minisatip-dvbapi/html -l3
TV is running "Das Erste"
then switching over to:

1. Station: SYFY
2. Station: RTL Crime
3. Station: n-tv HD
4. Station. "Das Erste HD"

Both CI slots are supplied with an ACL R2.2 (working cards are inserted)

Entire log is attached.
Attachments
minisatip.tgz
(210.47 KiB) Downloaded 5 times

carter
Posts: 11
Joined: Fri Jun 30, 2017 10:54 am

Re: MCD / MTD support using DD hardware

Post by carter » Mon Jun 04, 2018 2:20 pm

BTW:

Are there any add. plans to get access to the CAM menu, via WebIf?

-carter

carter
Posts: 11
Joined: Fri Jun 30, 2017 10:54 am

Re: MCD / MTD support using DD hardware

Post by carter » Sun Jun 10, 2018 8:33 am

...any further instructions?
...any - yet unknown - commandline parameters for DDCI to get it working?

-carter

BTW: I've also tested commit 664 "do not timeout ddci adapter"

cata
Site Admin
Posts: 436
Joined: Tue May 12, 2015 1:01 am

Re: MCD / MTD support using DD hardware

Post by cata » Sat Jun 16, 2018 10:57 pm

Please set in src/Makefile:
DDCI=1

make clean
make

./minisatip -f -l http,ca -v ca | tee /tmp/log
You should see something like this in the log:

[17/06 00:21:24.737 main]: DDCI opening [2] adapter 2 and frontend 0
[17/06 00:21:24.737 main]: opened DDCI adapter 2 fe:11 dvr:12
[17/06 00:21:24.737 main]: deleting pids on adapter 2, sid -1, pids=NULL
[17/06 00:21:24.737 main]: Mutex init 0x55af3e275758
[17/06 00:21:24.737 main]: sockets_add: handle 12 (type 5) returning socket index 9 [0.0.0.0:0] read: 0x55af3d786e4b
[17/06 00:21:24.737 main]: set_socket_thread: thread 23fff700 for sockets 9
[17/06 00:21:24.737 AD2]: Starting select_and_execute on thread ID 23fff700, thread_name AD2
[17/06 00:21:28.346 main]: initializing CA2, fd 13 type 2 flags 0x3, after 3609 ms
[17/06 00:21:28.347 main]: slotid: 0
[17/06 00:21:28.347 main]: tcid: 1
...................
[17/06 00:21:35.620 CA2]: 00:CAM successfully connected to resource 00240041, session_number 4

Then tune to a channel that your card should open, then upload the /tmp/log here

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests