CI+ protocol implementation in minisatip

Support forum for minisatip
9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: CI+ protocol implementation in minisatip

Post by 9000h » Sun Jan 27, 2019 4:33 pm

Hi,
deleted

CU
9000h
Last edited by 9000h on Mon Jan 28, 2019 1:25 pm, edited 1 time in total.

Yuri
Posts: 41
Joined: Thu Oct 01, 2015 7:26 pm

Re: CI+ protocol implementation in minisatip

Post by Yuri » Mon Jan 28, 2019 7:12 am

Hi,
what your source of ca.c-ci-plus? :)
BR,
Yuri

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: CI+ protocol implementation in minisatip

Post by 9000h » Mon Jan 28, 2019 7:44 am


Yuri
Posts: 41
Joined: Thu Oct 01, 2015 7:26 pm

Re: CI+ protocol implementation in minisatip

Post by Yuri » Mon Jan 28, 2019 12:50 pm

Hi,
actual version always in first post in this theme.
BR,
Yuri

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: CI+ protocol implementation in minisatip

Post by 9000h » Mon Jan 28, 2019 1:24 pm

Hi Yuri,

did overlook that.

thanks
9000h

balou1974
Posts: 23
Joined: Sat Mar 10, 2018 8:23 pm

Re: CI+ protocol implementation in minisatip

Post by balou1974 » Thu May 02, 2019 7:14 pm

Hello!

I am trying to use a technotrend CT2-4650 CI with latest git/Yuris latest patch and the certs - the free channels are working fine (dvb-c, german unitymedia with org. modul and smartcard) but the CA0 is not working.

This is my start-command: /usr/bin/minisatip -a 0:0:1 -Y 1:dvbc -e 0 -l 0 -f -v ca

and this is what happens:

[02/05 21:19:34.131 main]: initializing CA, fd 9 type 2 flags 0x1, after 8070 ms
[02/05 21:19:34.131 main]: CA module not present or not ready
[02/05 21:19:34.132 main]: closing CA device 0, fd -1

Maybe anyone has an idea what is wrong?

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: CI+ protocol implementation in minisatip

Post by 9000h » Fri May 03, 2019 5:20 am

Hi,
not sure if this is still valid, but there seem to be known issues for your card cam support.
https://www.linuxtv.org/wiki/index.php/ ... T2-4650_CI
CU
9000h

balou1974
Posts: 23
Joined: Sat Mar 10, 2018 8:23 pm

Re: CI+ protocol implementation in minisatip

Post by balou1974 » Sat May 04, 2019 5:32 am

Hello 9000H!

It seems that the CAM (Nagra) has a very slow init and after a few seconds the driver stops because of a timeout... I have found a few patches on different sites but I do not know which one will solve my problem. Another problem is that I do not have another cam to test. Trying to trigger another caminit with gnutv does not fix the problem either, init simply takes to long I think ...

sardonis
Posts: 11
Joined: Sat Jun 17, 2017 7:10 pm

Re: CI+ protocol implementation in minisatip

Post by sardonis » Mon May 06, 2019 6:08 pm

balou1974 wrote:
Sat May 04, 2019 5:32 am
Hello 9000H!

It seems that the CAM (Nagra) has a very slow init and after a few seconds the driver stops because of a timeout... I have found a few patches on different sites but I do not know which one will solve my problem. Another problem is that I do not have another cam to test. Trying to trigger another caminit with gnutv does not fix the problem either, init simply takes to long I think ...
I have the same TT card as you, working without any problems.

Did you install the dvb-apps package? You need libdvben50221 in order to have support for CAMS.
When you insert the CAM module into the dvb card, you should see it being detected in DMESG

Also libdvbcsa1 and libdvbcsa-dev are needed. Then compile with DVBCSA=YES

balou1974
Posts: 23
Joined: Sat Mar 10, 2018 8:23 pm

Re: CI+ protocol implementation in minisatip

Post by balou1974 » Thu May 09, 2019 12:31 pm

Hello sardonis!

Here is my config:

./minisatip --help

minisatip version 0.7.16, compiled with s2api version: 050A
[09/05 13:59:37.482 main]: Built with dvbcsa
[09/05 13:59:37.483 main]: Built with CI
[09/05 13:59:37.483 main]: Built with dvbapi
[09/05 13:59:37.483 main]: Built with AES (OpenSSL)
[09/05 13:59:37.483 main]: Built with tables processing
[09/05 13:59:37.483 main]: Built with pmt processing
[09/05 13:59:37.483 main]: Built with satip client
[09/05 13:59:37.483 main]: Built with linux dvb client
[09/05 13:59:37.483 main]: Built with backtrace
[09/05 13:59:37.483 main]: Built without netceiver
[09/05 13:59:37.483 main]: Built without ddci
[09/05 13:59:37.483 main]: Built without t2mi

I am using an raspberry pi 3B with latest raspbian:
dvb-apps, openssl-dev, libdvbcsa-dev and libdvbcsa1 are installed
(did I miss some packets?)

And my /etc/rc.local:
./cat /etc/rc.local |grep minis
/usr/bin/minisatip -a 0:0:1 -Y 1:dvbc -e 0 -l 0

Maybe you have an idea what I am doing wrong (cam is UM CI+ and SC UM02) ...

Thanks a lot for your help!

Post Reply