Minisatip with OpenATV 6.2 - Oscam Issue

Support forum for minisatip
Post Reply
Night Owl
Posts: 4
Joined: Tue Jun 26, 2018 8:52 pm

Minisatip with OpenATV 6.2 - Oscam Issue

Post by Night Owl » Tue Jun 26, 2018 9:34 pm

Hi,

first of all thank you for this great project. It is a masterpiece, that´s for sure.

Sorry, if my question may sound stupid but I am not a Linux Pro and therefore I would like to ask and understand if and how my setup could work.

I have OpenATV 6.2 running on a Gigablue X3 and installed Minisatip to work together without stopping Enigma 2. While FTA programs (both HD and SD) are working quite perfectly, I can´t figure out how I should get Oscam working to descramble directly on the server. Oscam is installed and working fine using it on OpenATV. But using it with Minisatip won´t work for me so far.
I have setup dvbapi to listen on port 9002 and tried afterwards to point oscam to that port. But using -o --dvbapi host:port is not working for me. I always get -bash: -o: command not found back. Do I need to install something else before it works or am I doing something wrong? Perhaps I have a logic error and that´s why it is not working.

Any further explanation and/or help is greatly appreciated.

Thanks

cata
Site Admin
Posts: 483
Joined: Tue May 12, 2015 1:01 am

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by cata » Wed Jun 27, 2018 4:36 am

Try

./minisatip -f -l http -o localhost:9002

And provide the output if it does not work

Night Owl
Posts: 4
Joined: Tue Jun 26, 2018 8:52 pm

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by Night Owl » Sun Jul 01, 2018 6:07 pm

Hi cata,

thanks for the fast reply - I tried ./minisatip -f -l http -o localhost:9002 which wasn´t working for me so I left ./ away and get below Output. Not sure why I get "error Address already in use" and "tcp_listen: failed"


[01/07 19:36:03.288 main]: minisatip version 0.7.15, compiled with s2api version: 050A
[01/07 19:36:03.289 main]: Built with dvbcsa
[01/07 19:36:03.289 main]: Built without CI
[01/07 19:36:03.289 main]: Built with dvbapi
[01/07 19:36:03.289 main]: Built with AES (OpenSSL)
[01/07 19:36:03.289 main]: Built with tables processing
[01/07 19:36:03.289 main]: Built with pmt processing
[01/07 19:36:03.289 main]: Built with satip client
[01/07 19:36:03.289 main]: Built with linux dvb client
[01/07 19:36:03.290 main]: Built with backtrace
[01/07 19:36:03.290 main]: Built without netceiver
[01/07 19:36:03.292 main]: New UDP socket 3 bound to 0.0.0.0:1900
[01/07 19:36:03.292 main]: setting multicast for 239.255.255.250
[01/07 19:36:03.292 main]: New UDP socket 4 bound to 239.255.255.250:1900
[01/07 19:36:03.293 main]: tcp_listen: failed: bind() on address: ANY, port 554 : error Address already in use

Thanks

cata
Site Admin
Posts: 483
Joined: Tue May 12, 2015 1:01 am

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by cata » Sun Jul 01, 2018 11:29 pm

Hi,

Most likely another instance of minisatip is running.

Run
killall minisatip;sleep 5;./minisatip -f -l http -o localhost:9002

Thanks

Night Owl
Posts: 4
Joined: Tue Jun 26, 2018 8:52 pm

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by Night Owl » Tue Jul 03, 2018 7:49 pm

Hi cata,

Thanks for your patience and assist. It works now. It takes a while until channels are descrambeled and getting visual artifacts but maybe the reason for this is the hardware I am using and/or I need to fine tune the settings of Oscam. Anyway I am happy that it works now.

Just a final question if I start Minisatip like the way you mentioned I don't have the webinterface on 8080 available anymore. Is there a way to start it as well? If not it isn't a big thing and you can close the thread.

Again, thanks a lot

cata
Site Admin
Posts: 483
Joined: Tue May 12, 2015 1:01 am

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by cata » Wed Jul 04, 2018 5:21 pm

You need to have the "html" directory where u start the command from or -R path to html directory.

Night Owl
Posts: 4
Joined: Tue Jun 26, 2018 8:52 pm

Re: Minisatip with OpenATV 6.2 - Oscam Issue

Post by Night Owl » Fri Jul 06, 2018 11:00 am

Thanks a lot!

Best regards

Post Reply