ATSC use?

Support forum for minisatip
Post Reply
SalPal
Posts: 8
Joined: Fri Feb 01, 2019 1:12 am

ATSC use?

Post by SalPal » Fri Feb 01, 2019 1:23 am

Can anybody please help with ATSC examples? Somehow there is none anywhere I look. :(
Specifically separately for QAM and VSB ( equivalent to DVB's T and C).

Thanks!

cata
Site Admin
Posts: 525
Joined: Tue May 12, 2015 1:01 am

Re: ATSC use?

Post by cata » Fri Feb 01, 2019 1:47 am

ATSC should work, at least the terstrial version. If it does not please upload the logs.

./minisatip -f -l http

SalPal
Posts: 8
Joined: Fri Feb 01, 2019 1:12 am

Re: ATSC use?

Post by SalPal » Fri Feb 22, 2019 3:57 am

After long nights I was able to successfully tune with w_scan and tvheadend works, so system is confirmed.

Interestingly, in tvheadend it appeared as two independent inputs with every single parameter identical, including: frontend0, dvr0, demux0 and device path. The only difference is the names: "ATSC-T #0" and "ATSC-C #0"

Cata,

I did fire it up with verbose switch you've suggested. As expected it is mostly HTTP chatter. from that I cannot figure out URL to start streaming.

more from the same verbose session:


[21/02 21:20:19.373 main]: trying to open [0] adapter 0 and frontend 0
[21/02 21:20:19.374 main]: opened DVB adapter 0 fe:7 dvr:8
[21/02 21:20:19.376 main]: DVR buffer set to 5775360 bytes
[21/02 21:20:19.376 main]: deleting pids on adapter 0, sid -1, pids=NULL
[21/02 21:20:22.403 main]: Detected adapter 0 handle 7 DVB Card Name: Auvitek AU8522 QAM/8VSB Frontend
[21/02 21:20:22.403 main]: Detected delivery system for adapter 0: atsc [11]
[21/02 21:20:22.403 main]: Detected delivery system for adapter 0: dvbcb [2]
[21/02 21:20:22.403 main]: Mutex init 0x2034390
[21/02 21:20:22.403 main]: sockets_add: handle 8 (type 5) returning socket sock 7 [0.0.0.0:0] read: 0x455eb5
[21/02 21:20:22.403 main]: set_socket_thread: thread b64ff270 for sockets 7
[21/02 21:20:22.403 main]: done opening adapter 0 delivery systems: atsc undefined undefined undefined
[21/02 21:20:22.404 AD0]: Starting select_and_execute on thread ID b64ff270, thread_name AD0
[21/02 21:20:22.404 main]: FE 1 mapped to Adapter 0, sys atsc
[21/02 21:20:22.404 main]: FE 2 mapped to Adapter 0, sys dvbcb
[21/02 21:20:22.404 main]: done init_hw 1
[21/02 21:20:22.404 main]: Initializing with 1 devices
"
"DVBCB" (a.k.a. ATSC QAM, is FE2). Looking at start switches option looks like I should start it instead with "./minisatip -f --dmx-source 0:2"

Actually I'm not sure this is correct because TVH has both modulations as fe0 and this switch made no difference.

I'm trying to open stream with VLC:



Accept: */*
Accept-Language: en_US
User-Agent: VLC/3.0.0 LibVLC/3.0.0
Range: bytes=0-
GET /?msys=atsc&freq=213&pids=65,68 (confirmed working open cable channel)

It is not clear if frequency should be in MHz or KHz or Hz? I've tried all of them, no difference. You see below different number of zerows.

[21/02 21:20:24.616 main]: detect_dvb_parameters (S)-> msys=atsc&freq=213&pids=65,68
[21/02 21:20:24.616 main]: detect_dvb_parameters (E) -> src=0, fe=0, freq=213000, fec=9, sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68 - apids=NULL - dpids=NULL x_pmt=NULL
[21/02 21:20:24.617 main]: Setup stream -1 parameters, sock_id 8, handle 9
[21/02 21:20:24.617 main]: stream.c:196 get_sid returns NULL for s_id = -1
[21/02 21:20:24.617 main]: Mutex init 0x4aab18
[21/02 21:20:24.617 main]: Mutex init 0x2048450
[21/02 21:20:24.617 main]: set_sock_lock: sock_id 8 locks also mutex 0x2048450
[21/02 21:20:24.617 main]: Mutex init 0x2049008
[21/02 21:20:24.618 main]: sockets_add: handle -2 (type 0) returning socket sock 9 [0.0.0.0:0] read: 0x455f3d
[21/02 21:20:24.618 main]: set_sock_lock: sock_id 9 locks also mutex 0x2048450
[21/02 21:20:24.618 main]: Setup stream done: sid: 0 for sock 8 handle 9
[21/02 21:20:24.618 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=6, plts=2, bw=8000000, inv=2, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:20:24.618 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:20:24.619 main]: Updating stream 0 time to 5367, current time 5371
[21/02 21:20:24.619 main]: Play for stream 0, type 1, rsock 9, adapter -1, sock_id 8, rsock_id 8, handle 9
[21/02 21:20:24.619 main]: stream.c:266: get_adapter returns NULL for adapter_id -1
[21/02 21:20:24.619 main]: adapter.c:1179: get_adapter returns NULL for adapter_id -1
[21/02 21:20:24.619 main]: adapter.c:2218: get_adapter returns NULL for adapter_id -1
[21/02 21:20:24.620 main]: stream.c:275: get_adapter returns NULL for adapter_id -1
[21/02 21:20:24.620 main]: get free adapter 0 - a[0] => e:1 m:-1 sid_cnt:0 f:0 pol=0 sys: atsc undefined
[21/02 21:20:24.620 main]: Got adapter 0 on stream 0 socket 8
[21/02 21:20:24.620 main]: set adapter 0 for stream 0 m:0 s:1
[21/02 21:20:24.620 main]: setting DVB parameters for adapter 0 - master_sid 0 sid 0 old f:0
[21/02 21:20:24.621 main]: deleting pids on adapter 0, sid -1, pids=NULL
[21/02 21:20:24.621 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=0, plts=2, bw=8000000, inv=0, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:20:24.621 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:20:24.621 main]: deleting pids on adapter 0, sid 0, pids=NULL
[21/02 21:20:24.622 main]: adding pids to adapter 0, sid 0, pids=65,68
[21/02 21:20:24.622 main]: Dumping pids table for adapter 0, pid errors 0
[21/02 21:20:24.622 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[21/02 21:20:24.623 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1


I see "fe" is still default "0", so I've added to VLC URL "&fe=2"


detect_dvb_parameters (S)-> msys=atsc&freq=213000&fe=2&pids=65,68
[21/02 21:46:22.803 main]: detect_dvb_parameters (E) -> src=0, fe=2, freq=213000000, fec=9, sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68 - apids=NULL - dpids=NULL x_pmt=NULL
[21/02 21:46:22.804 main]: Setup stream -1 parameters, sock_id 8, handle 9
[21/02 21:46:22.804 main]: stream.c:196 get_sid returns NULL for s_id = -1
[21/02 21:46:22.804 main]: Mutex init 0x4b8b18
[21/02 21:46:22.804 main]: Mutex init 0x1c52450
[21/02 21:46:22.805 main]: set_sock_lock: sock_id 8 locks also mutex 0x1c52450
[21/02 21:46:22.805 main]: Mutex init 0x1c53008
[21/02 21:46:22.805 main]: sockets_add: handle -2 (type 0) returning socket sock 9 [0.0.0.0:0] read: 0x463f3d
[21/02 21:46:22.805 main]: set_sock_lock: sock_id 9 locks also mutex 0x1c52450
[21/02 21:46:22.805 main]: Setup stream done: sid: 0 for sock 8 handle 9
[21/02 21:46:22.806 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=6, plts=2, bw=8000000, inv=2, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:46:22.806 main]: copy_dvb_parameters -> src=1, fe=2, freq=213000000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:46:22.806 main]: Play for stream 0, type 1, rsock 9, adapter -1, sock_id 8, rsock_id 8, handle 9
[21/02 21:46:22.806 main]: stream.c:266: get_adapter returns NULL for adapter_id -1
[21/02 21:46:22.806 main]: adapter.c:1179: get_adapter returns NULL for adapter_id -1
[21/02 21:46:22.807 main]: adapter.c:2218: get_adapter returns NULL for adapter_id -1
[21/02 21:46:22.807 main]: stream.c:275: get_adapter returns NULL for adapter_id -1
[21/02 21:46:22.807 main]: get free adapter 2 - a[0] => e:1 m:-1 sid_cnt:0 f:0 pol=0 sys: atsc undefined
[21/02 21:46:22.807 main]: new parameters: f:213000000, plp/isi:-1, diseqc:1, pol:0, sr:0, mtype:6
[21/02 21:46:22.808 main]: old parameters: f:0, plp/isi:-1, diseqc:0, pol:0, sr:0, mtype:0
[21/02 21:46:22.808 main]: Got adapter 0 on stream 0 socket 8
[21/02 21:46:22.809 main]: set adapter 0 for stream 0 m:0 s:1
[21/02 21:46:22.809 main]: setting DVB parameters for adapter 0 - master_sid 0 sid 0 old f:0
[21/02 21:46:22.809 main]: new parameters: f:213000000, plp/isi:-1, diseqc:1, pol:0, sr:0, mtype:6
[21/02 21:46:22.809 main]: old parameters: f:0, plp/isi:-1, diseqc:0, pol:0, sr:0, mtype:0
[21/02 21:46:22.809 main]: deleting pids on adapter 0, sid -1, pids=NULL
[21/02 21:46:22.810 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=0, plts=2, bw=8000000, inv=0, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:46:22.810 main]: copy_dvb_parameters -> src=1, fe=2, freq=213000000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=6, plts=2, bw=8000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[21/02 21:46:22.810 main]: deleting pids on adapter 0, sid 0, pids=NULL
[21/02 21:46:22.811 main]: adding pids to adapter 0, sid 0, pids=65,68
[21/02 21:46:22.811 main]: Dumping pids table for adapter 0, pid errors 0
[21/02 21:46:22.811 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[21/02 21:46:22.812 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[21/02 21:46:22.812 main]: set_socket_thread: thread b64ff270 for sockets 9
[21/02 21:46:22.812 main]: DMX_SET_SOURCE failed for adapter 0 - 25: Inappropriate ioctl for device
[21/02 21:46:22.813 main]: Frequency 213000000 is not within range
[21/02 21:46:22.813 main]: Adding pid 0 to the list of pids as not explicitly added for adapter 0
[21/02 21:46:22.813 main]: Mutex init 0x4ba3f8
[21/02 21:46:22.814 main]: Mutex init 0x1c53118
[21/02 21:46:22.814 main]: new filter 0 added for adapter 0, pid 0, flags 20, mask_len 0, master_filter 0
[21/02 21:46:22.815 main]: Mutex init 0x1c53b80
[21/02 21:46:22.815 main]: new filter 1 added for adapter 0, pid 17, flags 20, mask_len 0, master_filter 1
[21/02 21:46:22.815 main]: deleting pids on adapter 0, sid 0, pids=NULL
[21/02 21:46:22.815 main]: Found 0 filters for adapter 0 pid 0 master 0 with flags 1
[21/02 21:46:22.817 main]: Dumping pids table for adapter 0, pid errors 0
[21/02 21:46:22.817 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 3, pmt -1, filter -1, sock -1, sids: -1 -1 -1 -1 -1 -1 -1 -1
[21/02 21:46:22.817 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 3, pmt -1, filter -1, sock -1, sids: -1 -1 -1 -1 -1 -1 -1 -1
[21/02 21:46:22.817 main]: pid 0, fd 0, packets 0, d/c errs 0/0, flags 3, pmt -1, filter 0, sock -1, sids: -1 -1 -1 -1 -1 -1 -1 -1
[21/02 21:46:22.818 main]: Dumping pids table for adapter 0, pid errors 0

It did switch FronEnd to 2 (cable, maybe?) but still no lock.

I'm at loss how to form ATSC URL.

SAT>IP document does not have specs for ATSC, at least I cannot find it.
I have other sat>ip satellite tuners that I'm using with VLC. It is setup with custom local M3U. I would love to add some cable channels to it.

With URLs like above, VLC just getting 404. I'm guessing that variables not parsed as expected:

"http debug: http: server='192.168.1.138' port=8080 file='/'
main debug: net: connecting to 192.168.1.138 port 8080
main debug: connection succeeded (socket = 2484)
http debug: sending request: GET /?msys=atsc&freq=213000&fe=1&pids=65,68 HTTP/1.0 Host: 192.168.1.138:8080 User-Agent: VLC/3.0.0 LibVLC/3.0.0 Icy-MetaData: 1
http debug: HTTP answer code 404
http error: error: HTTP/1.0 404 Not Found"



On GitHub you have examples for DVB-S. For ATSC there should be obviously frequency and PIDs and some way to select Cable vs Terrestrial.

Could you please provide URL examples for ATSC?

Your help is greatly appreciated!

Sal

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: ATSC use?

Post by 9000h » Fri Feb 22, 2019 7:39 am

Hi,
there is unfortunately still no official SAT>IP specification for ATSC. From what I know there is only one device out which implements SAT>IP and ATSC in a commercial device.
http://www.hauppauge.com/pages/products ... tertv.html

not sure if this can be a reference.
CU
9000h

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: ATSC use?

Post by 9000h » Fri Feb 22, 2019 8:20 am

Hi,
in the code from this device are some fragments how they have implement ATSC stuff.

Code: Select all

&bw=8.000000&msys=dvbt&mtype=8vsb&wait=
&bw=6.000000&msys=isdbt&mtype=8vsb&wait=
&bw=6.000000&msys=atsc&mtype=8vsb&wait=
&bw=8.000000&msys=dvbs&mtype=8vsb&wait=
&bw=8.000000&msys=cmmb&mtype=8vsb&wait=
&bw=8.000000&msys=dvbc&mtype=8vsb&wait=
&bw=6.000000&msys=dab&mtype=8vsb&wait=
&bw=6.000000&msys=atsc&mtype=qam64&wait=
&bw=6.000000&msys=atsc&mtype=qam128&wait=
&bw=6.000000&msys=atsc&mtype=qam256&wait=

DVB-C-%d
DVB-T2-%d
DVB-S2-%d
ATSC-%d

ver=1.2;tuner=%d,%d,%d,%d,%.2f,%s,%s,%d,%d
ver=1.1;tuner=%d,%d,%d,%d,%.2f,%d,%s,%s,%s,%d,%d,%d,%d,%d
ver=1.0;src=%d;tuner=%d,%d,%d,%d,%.2f,%s,%s,%s,%s,%.2f,%d,%d

RTP/AVP;%s;destination=%s;%sport=%d-%d%s

there is "wait=" which does not exist in the SAT>IP spec, and also "dab" and "cmmb".

the device can also trans-code something.
this is a picture from inside
https://www.avsforum.com/forum/attachme ... 1527427735
CU
9000h

SalPal
Posts: 8
Joined: Fri Feb 01, 2019 1:12 am

Re: ATSC use?

Post by SalPal » Sat Feb 23, 2019 2:26 am

9000h,
Thanks for the hint!

As I understand your excerpt is from Hauppage device?

I'm not sure what to do with "wait" and other options: "dab" and "cmmb".

So new URL will be:
...?bw=6&msys=atsc&mtype=qam256&freq=213&pids=65,68

It appeared that modulation type not parsed and not used in processing. So msys parsed into correct enumerated option (11 for ATSC) but mtype does not, it stayed default (0). Maybe syntax I use for "qam256" is wrong? You see in second log below it is tuning to ATSC with QPSK modulation (option 0), which is wrong. I've tried capital letters and small single numbers in case it is enumerated - no luck, it still pass option zero. Maybe it is in the code? A bug?

There is bunch of other arguments that relevant only to satellite but somehow still processed. Not sure if they can spoil ATSC.


Actually first I use 213000 for F and got this F error:
"
[22/02 20:31:15.317 main]: read RTSP (from handle 10 sock 9, len: 185, sid -1):
[22/02 20:31:15.317 main]: detect_dvb_parameters (S)-> bw=6&msys=atsc&mtype=qam256&freq=213000&pids=65,68
[22/02 20:31:15.318 main]: detect_dvb_parameters (E) -> src=0, fe=0, freq=213000000, fec=9, sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68 - apids=NULL - dpids=NULL x_pmt=NULL
[22/02 20:31:15.318 main]: Setup stream -1 parameters, sock_id 9, handle 10
[22/02 20:31:15.318 main]: stream.c:196 get_sid returns NULL for s_id = -1
[22/02 20:31:15.318 main]: Mutex init 0x4e9b18
[22/02 20:31:15.319 main]: Mutex init 0xacc158
[22/02 20:31:15.319 main]: set_sock_lock: sock_id 9 locks also mutex 0xacc158
[22/02 20:31:15.319 main]: Mutex init 0xab0758
[22/02 20:31:15.319 main]: sockets_add: handle -2 (type 0) returning socket sock 10 [0.0.0.0:0] read: 0x494f3d
[22/02 20:31:15.319 main]: set_sock_lock: sock_id 10 locks also mutex 0xacc158
[22/02 20:31:15.320 main]: Setup stream done: sid: 0 for sock 9 handle 10
[22/02 20:31:15.320 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=6, plts=2, bw=8000000, inv=2, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 20:31:15.320 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 20:31:15.320 main]: Play for stream 0, type 1, rsock 10, adapter -1, sock_id 9, rsock_id 9, handle 10
[22/02 20:31:15.320 main]: stream.c:266: get_adapter returns NULL for adapter_id -1
[22/02 20:31:15.321 main]: adapter.c:1179: get_adapter returns NULL for adapter_id -1
[22/02 20:31:15.321 main]: adapter.c:2218: get_adapter returns NULL for adapter_id -1
[22/02 20:31:15.321 main]: stream.c:275: get_adapter returns NULL for adapter_id -1
[22/02 20:31:15.321 main]: get free adapter 0 - a[0] => e:1 m:-1 sid_cnt:0 f:0 pol=0 sys: atsc undefined
[22/02 20:31:15.321 main]: new parameters: f:213000000, plp/isi:-1, diseqc:1, pol:0, sr:0, mtype:0
[22/02 20:31:15.322 main]: old parameters: f:0, plp/isi:-1, diseqc:0, pol:0, sr:0, mtype:0
[22/02 20:31:15.322 main]: Got adapter 0 on stream 0 socket 9
[22/02 20:31:15.322 main]: set adapter 0 for stream 0 m:0 s:1
[22/02 20:31:15.322 main]: setting DVB parameters for adapter 0 - master_sid 0 sid 0 old f:0
[22/02 20:31:15.322 main]: new parameters: f:213000000, plp/isi:-1, diseqc:1, pol:0, sr:0, mtype:0
[22/02 20:31:15.322 main]: old parameters: f:0, plp/isi:-1, diseqc:0, pol:0, sr:0, mtype:0
[22/02 20:31:15.323 main]: deleting pids on adapter 0, sid -1, pids=NULL
[22/02 20:31:15.323 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=0, plts=2, bw=8000000, inv=0, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 20:31:15.323 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 20:31:15.324 main]: deleting pids on adapter 0, sid 0, pids=NULL
[22/02 20:31:15.324 main]: adding pids to adapter 0, sid 0, pids=65,68
[22/02 20:31:15.324 main]: Dumping pids table for adapter 0, pid errors 0
[22/02 20:31:15.325 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 20:31:15.325 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 20:31:15.325 main]: set_socket_thread: thread b64ff270 for sockets 10
[22/02 20:31:15.325 main]: DMX_SET_SOURCE failed for adapter 0 - 25: Inappropriate ioctl for device
[22/02 20:31:15.326 main]: Frequency 213000000 is not within range
"

Well, that produced tuning F out of range error. I guess switch in URL is in MHz

New URL:
?bw=6&msys=atsc&mtype=qam256&freq=213&pids=65,68

"
[22/02 19:33:47.108 main]: detect_dvb_parameters (S)-> bw=6.000000&msys=atsc&mtype=qam128&freq=213&pids=65,68
[22/02 19:33:47.108 main]: detect_dvb_parameters (E) -> src=0, fe=0, freq=213000, fec=9, sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68 - apids=NULL - dpids=NULL x_pmt=NULL
[22/02 19:33:47.109 main]: Setup stream -1 parameters, sock_id 7, handle 7
[22/02 19:33:47.109 main]: stream.c:196 get_sid returns NULL for s_id = -1
[22/02 19:33:47.109 main]: Mutex init 0x49ab18
[22/02 19:33:47.109 main]: Mutex init 0x1400560
[22/02 19:33:47.109 main]: set_sock_lock: sock_id 7 locks also mutex 0x1400560
[22/02 19:33:47.110 main]: Mutex init 0x13ec538
[22/02 19:33:47.110 main]: sockets_add: handle -2 (type 0) returning socket sock 8 [0.0.0.0:0] read: 0x445f3d
[22/02 19:33:47.110 main]: set_sock_lock: sock_id 8 locks also mutex 0x1400560
[22/02 19:33:47.110 main]: Setup stream done: sid: 0 for sock 7 handle 7
[22/02 19:33:47.110 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=6, plts=2, bw=8000000, inv=2, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 19:33:47.111 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 19:33:47.111 main]: Updating stream 0 time to 194262, current time 194266
[22/02 19:33:47.111 main]: Play for stream 0, type 1, rsock 7, adapter -1, sock_id 7, rsock_id 7, handle 7
[22/02 19:33:47.112 main]: stream.c:266: get_adapter returns NULL for adapter_id -1
[22/02 19:33:47.112 main]: adapter.c:1179: get_adapter returns NULL for adapter_id -1
[22/02 19:33:47.112 main]: adapter.c:2218: get_adapter returns NULL for adapter_id -1
[22/02 19:33:47.113 main]: stream.c:275: get_adapter returns NULL for adapter_id -1
[22/02 19:33:47.113 main]: get free adapter 0 - a[0] => e:0 m:-1 sid_cnt:0 f:0 pol=0 sys: atsc undefined
[22/02 19:33:47.113 main]: Mutex init 0x13ecdc8
[22/02 19:33:47.113 main]: trying to open [0] adapter 0 and frontend 0
[22/02 19:33:47.115 main]: opened DVB adapter 0 fe:8 dvr:9
[22/02 19:33:47.121 main]: DVR buffer set to 5775360 bytes
[22/02 19:33:47.121 main]: deleting pids on adapter 0, sid -1, pids=NULL
[22/02 19:33:47.122 main]: Mutex init 0x13ec648
[22/02 19:33:47.122 main]: sockets_add: handle 9 (type 5) returning socket sock 9 [0.0.0.0:0] read: 0x445eb5
[22/02 19:33:47.122 main]: set_socket_thread: thread b64ff270 for sockets 9
[22/02 19:33:47.123 main]: done opening adapter 0 delivery systems: atsc undefined undefined undefined
[22/02 19:33:47.123 main]: Got adapter 0 on stream 0 socket 7
[22/02 19:33:47.124 main]: set adapter 0 for stream 0 m:0 s:1
[22/02 19:33:47.124 main]: setting DVB parameters for adapter 0 - master_sid 0 sid 0 old f:0
[22/02 19:33:47.124 main]: deleting pids on adapter 0, sid -1, pids=NULL
[22/02 19:33:47.124 AD0]: Starting select_and_execute on thread ID b64ff270, thread_name AD0
[22/02 19:33:47.125 main]: copy_dvb_param start -> src=0, fe=0, freq=0, fec=9, sr=0, pol=0, ro=3, msys=0, mtype=6, plts=2, bw=8000000, inv=2, pids=NULL, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 19:33:47.125 main]: copy_dvb_parameters -> src=1, fe=0, freq=213000, fec=9 sr=0, pol=0, ro=3, msys=11, mtype=0, plts=2, bw=6000000, inv=2, pids=65,68, apids=NULL, dpids=NULL x_pmt=NULL
[22/02 19:33:47.125 main]: deleting pids on adapter 0, sid 0, pids=NULL
[22/02 19:33:47.126 main]: adding pids to adapter 0, sid 0, pids=65,68
[22/02 19:33:47.126 main]: Dumping pids table for adapter 0, pid errors 0
[22/02 19:33:47.126 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 19:33:47.127 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 19:33:47.127 main]: set_socket_thread: thread b64ff270 for sockets 8
[22/02 19:33:50.082 main]: DMX_SET_SOURCE failed for adapter 0 - 25: Inappropriate ioctl for device
[22/02 19:33:50.082 main]: tuning to 213000000 delsys:atsc mod:qpsk specinv: ts clear = 194282
[22/02 19:33:50.086 main]: Adding pid 0 to the list of pids as not explicitly added for adapter 0
[22/02 19:33:50.086 main]: Mutex init 0x49c3f8
[22/02 19:33:50.086 main]: Mutex init 0x1401288
[22/02 19:33:50.086 main]: new filter 0 added for adapter 0, pid 0, flags 20, mask_len 0, master_filter 0
[22/02 19:33:50.086 main]: Mutex init 0x1401cf0
[22/02 19:33:50.086 main]: new filter 1 added for adapter 0, pid 17, flags 20, mask_len 0, master_filter 1
[22/02 19:33:50.086 main]: Dumping pids table for adapter 0, pid errors 0
[22/02 19:33:50.086 main]: pid 65, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 19:33:50.086 main]: pid 68, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter -1, sock -1, sids: 0 -1 -1 -1 -1 -1 -1 -1
[22/02 19:33:50.086 main]: pid 0, fd 0, packets 0, d/c errs 0/0, flags 2, pmt -1, filter 0, sock -1, sids: -1 -1 -1 -1 -1 -1 -1 -1
[22/02 19:33:50.088 main]: AD 0 [demux 0 0], setting filter on PID 65 for fd 10
[22/02 19:33:50.088 main]: AD 0 [demux 0 0], setting filter on PID 68 for fd 11
[22/02 19:33:50.088 main]: AD 0 [demux 0 0], setting PSI filter on PID 0 for fd 12
[22/02 19:33:50.088 main]: Mutex init 0x13ec758
[22/02 19:33:50.088 main]: sockets_add: handle 12 (type 5) returning socket sock 10 [0.0.0.0:0] read: 0x445eb5
[22/02 19:33:50.089 main]: sock 9 is master for sock 10
[22/02 19:33:50.089 main]: reply -> 7 (192.168.1.110:50084) CL:0 [sock_id 7]:
[22/02 19:33:50.089 main]: HTTP/1.0 200 OK
Date: Sat, Feb 23 00:33:50 2019 GMT
Content-Type: video/mp2t
Connection: close
Server: minisatip/0.7.16
"

SalPal
Posts: 8
Joined: Fri Feb 01, 2019 1:12 am

Re: ATSC use?

Post by SalPal » Sat Feb 23, 2019 2:56 am

I can't believe it but I did figure it out:
....?bw=6.000000&msys=atsc&mtype=256qam&freq=213&pids=65,68
.........edit your own frequency and PIDs

It took me digging through source code to figure out right switches. So QAM256 must be written as "256qam".

ATSC-C QAM (256) confirmed working! :-)

Cheers Y'all

SalPal
Posts: 8
Joined: Fri Feb 01, 2019 1:12 am

Re: ATSC use?

Post by SalPal » Sat Feb 23, 2019 2:36 pm

Updates:

After some testing it appeared that bandwidth and modulation settings are optional. In source code they default to auto. In reality this may cause request to hang indefinitely (~1 of 4 calls) or more often delaying start of streaming by 5-6 seconds (this is probably why I initially missed it working). Specifying these parameters yield reliable answer within couple of seconds. I'm running it on OrangePi zero so it might be reduced hardware issue. Anyway, after specifying bw and mtype it works like a clock, even with full bandwidth muxes OPiZ stays essentially cold without heat sink. Nice!

freq is in MHz.

Not able to specify "all" PIDs - it hangs. Not specifying it yield random single stream from the mux. Strange.

ATSC icon missing from the HTML pack. I made one.
RF level meter is not scaled properly (Hauppauge 950Q). I can see proper raw value in verbose log. It appeared as only 0 or 1% on the interface. This is the same in most Linux apps so it is general Debian DVB problem rather than this app.


Next task is to auto generate playlist. w_scan supposedly can do it for VLC (experimental) but so far no luck. I have to manually create play list.

Is there any app for SAT>IP that can scan ATSC?

Cheers!

9000h
Posts: 49
Joined: Tue May 12, 2015 1:49 pm

Re: ATSC use?

Post by 9000h » Sun Feb 24, 2019 11:19 am

Hi,

to give you an idea https://github.com/localhosthack0r/chan2satip
it did convert from a vdr channels.conf to a m3u for dvb-s
CU
9000h

Post Reply