Page 1 of 1

Autostart: proper way on headless system...

Posted: Wed Mar 13, 2019 2:26 am
by SalPal
I'm running it very smoothly on OPiZ with Armbian and Hauppauge 950Q. That is with manual start, everything works as it should and all devices see it as SAT>IP. Great!

Now I'm attempting to setup auto-start:

in /etc/rc.local
sleep 5
cd /minisatip
sudo ./minisatip -p http://x.x.x.x/playlist.m3u &
exit 0
Actually play list is just for fun, not really needed and without it my result does not change.
With above auto-start it runs but VLC does not see announcement on Local Network/UPnP tab. I assume other SAT>IP clients would not see it either but I cannot check it right now.

Originally I run it with absolute path - This would return empty HTML. I did try "-R" option - this fixes HTML but still no local network announcement. With -p option is the same as if I first set local folder.

With auto-start above everything works, including page/status and HTTP and RTSP streaming, but still no local network announcement. The only way to make it work I know is to manually start it.

Why would there be any difference? In bot cases I'm root.
How can it be setup for auto-start to have full functionality?


Re: Autostart: proper way on headless system...

Posted: Wed Mar 13, 2019 8:29 am
by 9000h
the SSDP is multicast, if everithing else is working then look if your Armbian/Interface is configured right.

Re: Autostart: proper way on headless system...

Posted: Thu Mar 14, 2019 1:40 am
by SalPal
9000h, all,

" Armbian/Interface" I assume is network?
My network is on Auto and I see no problem with it:
source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto lo
iface lo inet loopback

And to clarify: everything works, including SSDP announcement, when program manually launched through SSH, I'm always root. I would think that this excludes networks or any other problem with settings, including network (interface?).

When trying to automate startup - after struggle with blank HTML I've found two options to make HTML functional: Either, set initial directory first (in my case "/minisatip" in root) or use -R option. Both works the same, apparently. I would suspect that this problem is not because of network settings or different user (always root or sudo) but different starting/home directory where execution initiates. I'm not sure. The fact is I'm getting SSDP working when manually started and no SSDP when automated. This is why I'm here.

One more hint: When specifying wrong HTML directory then even with manual start SSDP and HTML both do not work. Not sure if it is relevant or not.

Could you please clarify what settings /interface I need to check? Any other ides?


Re: Autostart: proper way on headless system...

Posted: Thu Mar 14, 2019 2:27 am
by SalPal
I might found the problem:
After looking at process list (# ps -aux) I found that my playlist in startup option was truncated after ".", there was no "...m3u" at the end. Guessing that whole string was not parsed properly I did include double quotes around URL for play list. After reboot it happily announced it's presence through SSDP. Checking running processes now I see whole startup string with m3u at the end.

It might be possible to update parsing of options in source code, URL specifically, to not disregard the dot in URL? Just a thought. Adding quotes is easy anyway, though only after you know it is absolutely needed.

Anyway, everything works now, even with auto-start.

In VLC, fter toggling "SAT>IP channel list" from and back to "Auto" it did pickup playlist from the Minisatip.

Now surfing channels on cable tv in VLC is as convenient as I can imagine it can be.

Fantastic! I'm happy.

Minisatip is great!