Questions about minisatip

Support forum for minisatip
retrofan

Questions about minisatip

Post by retrofan » Sat Oct 19, 2019 4:02 pm

Hi,

I do have some questions about minisatip:

1. There are some discontinuities in DVBViewer Pro at random when using minisatip for TV.
Can I increase a buffer or something? Or give minisatip a higher priority?
With radio channels, the interruptions are always 1-3 seconds when the stream starts.
This is annoying. Can you fix this please? (see attachment for log)

2. When using the RTSP server of OpenATV 6.2 the signal strength is shown as 0% in DVBViewer.
Can this be changed with an option to fake 100% signal strength just like the -M parameter for DVB HW?

3. When opening uPNP in VLC minisatip is displaying the wrong channellist (satellite).
Can you please fix this as well? It has to display the channels from xml file.

Thank you! I like this project!
Attachments
VLC uPNP.PNG
VLC uPNP.PNG (36.26 KiB) Viewed 406 times
minisatip.zip
(55.39 KiB) Downloaded 8 times

9000h
Posts: 65
Joined: Tue May 12, 2015 1:49 pm

Re: Questions about minisatip

Post by 9000h » Sat Oct 19, 2019 6:55 pm

Hi,
in VLC the playlist did got downloded by VLC from satip.info, nothing wrong with minisatip.
https://github.com/videolan/vlc/blob/cc ... p.cpp#L729
CU
9000h

retrofan

Re: Questions about minisatip

Post by retrofan » Sun Oct 20, 2019 9:31 am

Okay, I see, thanks.
Is there a way to get the playlist from the localhost instead from satip.info so channels can be streamed using DLNA as well?
This playlist in VLC is useless for me ;-)

retrofan

Re: Questions about minisatip

Post by retrofan » Sun Oct 20, 2019 4:57 pm

retrofan wrote:
Sat Oct 19, 2019 4:02 pm
Hi,

I do have some questions about minisatip:

1. There are some discontinuities in DVBViewer Pro at random when using minisatip for TV.
Can I increase a buffer or something? Or give minisatip a higher priority?
With radio channels, the interruptions are always 1-3 seconds when the stream starts.
This is annoying. Can you fix this please? (see attachment for log)
I only have discontinuities with the RTSP server in OpenATV 6.3 (-N --satip-xml http://127.0.0.1:8554). Not with DVB HW (Enigma2 uses http protocol)

I tried to change SAT>IP URL from rtsp xxxx:554 to http xxxx:8080 to change protocol, and then also no discontinuities as well, so it must be something wrong with RTSP protocol.
Could it be a bug in RTSP source code of minisatip or maybe I need to change port for RTSP on my Enigma2 receiver as there might be a conflict?
This can be done with -y right? What can I do to fix this?

9000h
Posts: 65
Joined: Tue May 12, 2015 1:49 pm

Re: Questions about minisatip

Post by 9000h » Sun Oct 20, 2019 5:47 pm

Hi,
no I think your issue is the UDP protocol, most probably bad network settings,cables or equipent.
CU
9000h

retrofan

Re: Questions about minisatip

Post by retrofan » Mon Oct 21, 2019 3:37 pm

Cables and equipment are fine. What network settings are you referring to?

9000h
Posts: 65
Joined: Tue May 12, 2015 1:49 pm

Re: Questions about minisatip

Post by 9000h » Mon Oct 21, 2019 8:54 pm

Hi,
like https://github.com/catalinii/minisatip/ ... t-71306945

do nstat -a |grep Udp and look for errors

broken driver like hxxps://sourceforge.net/p/e1000/mailman/message/30922613/
....
do some tests with iperf
server iperf -M 1000 -u -s
client iperf -M 1000 -u -c 192.168.10.1 -d -t 30

CU
9000h

retrofan

Re: Questions about minisatip

Post by retrofan » Tue Oct 22, 2019 4:49 pm

Hi, thanks. I will try.
But why I don't have this issue with http / tcp protocol?
So probably it's my Intel NIC what's causing this issue? More people having this issue?

9000h
Posts: 65
Joined: Tue May 12, 2015 1:49 pm

Re: Questions about minisatip

Post by 9000h » Tue Oct 22, 2019 6:28 pm

Hi,
you have to take in account TCP is more robust and has error correction, UDP is faster but if you loose something then its gone.
CU
9000h

retrofan

Re: Questions about minisatip

Post by retrofan » Mon Oct 28, 2019 10:16 am

No problems with minisatip when using the DVB hardware directly.
I only have problems when using the hardware indirectly with RTSP server of Enigma2 (OpenATV 6.3).
Then I have interruptions when streaming.
I need to use the RTSP server as this is the only way for me to watch encrypted channels using cip from Enigma2.
What to do?
I already tried another NIC, but this isn't the solution.
Maybe there's a bug in OpenATV with RTSP server?

Post Reply