minisatip vs VU+ Uno 4K and Tvheadend

Support forum for minisatip
cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am
Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Sat Apr 11, 2020 12:21 am

Also can you run minisatip without enigma2, does that work ?

franky646464
Posts:11
Joined:Sun Apr 05, 2020 6:17 pm

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by franky646464 » Sat Apr 11, 2020 7:18 am

ok, i think you mean /var/log/messages? I have with enigma2 and after them
i stopped enigma2 with init 4 and tested again. Result the same
Attachments
messages.rar
(21.22KiB)Downloaded 53 times

cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Tue Apr 14, 2020 1:30 am

In enigma2 process you can enable debug logging (From UI is much easier). Then the engima2 process will save a log.
In my /etc/enigma2/settings:
config.crash.debug_path=/media/sdb2/logs/
config.crash.debugloglimit=4
config.crash.enabledebug=true

Then attach both enigma2 and minisatip logs.
./minisatip -f -l http

Thank you

franky646464
Posts:11
Joined:Sun Apr 05, 2020 6:17 pm

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by franky646464 » Fri Apr 17, 2020 12:46 pm

i have tested several more times, but today i only had one picture, also this one was full of hooks and sticks.

I see in TVH that he is trying one tuner after the other, but nowhere a signal is coming. As I said only once. I also did another test with init 4, shut down the Enigma 2, result was the same.

I set the debug level in vu+ as desired. I wrote several logs.

Hier are the logfiles
https://we.tl/t-CxfXh5P2Pa

cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Sat Apr 18, 2020 3:50 am

By looking at the enigma2 logs I see:
13:36:26.1449 [ ] dvb/frontend.cpp:3129 prepare_sat [eDVBFrontend1] prepare_sat System 1 Freq 10891000 Pol 0 SR 22000000 INV 0 FEC 2 orbpos 192 system 1 modulation 2 pilot 2, rolloff 0, is_id -1, pls_mode 1, pls_code 0, t2mi_plp_id -1 t2mi_pid 4096
13:36:26.1449 [ ] dvb/frontend.cpp:3152 prepare_sat tuning to 1025 MHz
13:36:26.1450 [ ] dvb/dvb.cpp:1893 frontendStateChanged [eDVBChannel] OURSTATE: tuner 1 tuning
13:36:26.1450 [ E ] dvb/pmt.cpp:116 channelStateChanged [eDVBServicePMTHandler] tune failed.
13:36:26.1450 [ ] service/servicedvbstream.cpp:26 serviceEvent [eDVBServiceStream] STREAM service event 1
13:36:26.1450 [ E ] dvb/rtspstreamserver.cpp:711 eventUpdate eventUpdate TuneFailed

Which shows that enigma2 is also failing to tune

On minisatip side it also shows no signal:

[17/04 13:32:43.167 signal]: get_signal took 72 ms for adapter 3 handle 11 (status: 7, ber: 0, strength:76, snr: 0, force scan 0)
[17/04 13:32:53.272 signal]: get_signal took 78 ms for adapter 4 handle 13 (status: 7, ber: 0, strength:76, snr: 0, force scan 0)
[17/04 13:32:53.963 signal]: get_signal took 89 ms for adapter 7 handle 19 (status: 7, ber: 0, strength:81, snr: 0, force scan 0)
[17/04 13:33:05.241 signal]: get_signal took 91 ms for adapter 1 handle 7 (status: 7, ber: 0, strength:81, snr: 0, force scan 0)

I would really suggest checking the cables, or testing with a very strong transponder (qpsk modulation)

franky646464
Posts:11
Joined:Sun Apr 05, 2020 6:17 pm

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by franky646464 » Sat Apr 18, 2020 8:51 am

Hello, Cata,

as I already wrote I watch TV with the receiver perfectly, I emphasize again that the tuners are configured with UnicableII/Jess. Maybe this is a problem.

I have now once again normal on the receiver a FTA channel run, then via web interface and VLC another 3 channels, on different transponders, started so that 4 tuners "were in operation".

After that I started minisatip.

It is the same problem.

Is it maybe easier for you if I let you access the devices via anydesk?
Then write me via PN how I can reach you in a messenger.

I have written logs of the whole scenario

Logs about wetransfer, because too big for the forum.

https://we.tl/t-VrXczb8YXV

cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Sat Apr 18, 2020 8:40 pm

By default you need to specify as command line options the unicable/jess setup. Were you able to identify the command line options needed or you need help with that?

cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Sat Apr 18, 2020 8:51 pm

I also see in this logs that the minisatip was running while enigma2 is running (which is not good, as minisatip will not be able to use the master tuners - 0 and 1 which are associated with the physical connections)

franky646464
Posts:11
Joined:Sun Apr 05, 2020 6:17 pm

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by franky646464 » Sun Apr 19, 2020 1:44 pm

we're gonna start over from scratch:

newly installed openatv on a VU+ uno 4k
Unicable Jess LNB with 24 slots
The tuners are set up. 8 tuners with the first 8 SCR

With the VU+ on enigma2 I can use all 8 tuners, record 1 show watching others.

Then:

opkg update
opkg upgrade
opkg install minisatip

then I start minisatip (etc/init.d)

I have another Ubuntu machine, there is Tvheadend installed
I already have an Octupus Net running there via SAT>IP. 2Tuner are in use there
I've got this running smoothly.

Now I see the tuners, I activate the tuners. The tuners of the Octupus Net are busy and running, if I want to start another channel from Tvheadend now, I see that Tvheadend tries to use the tuners of VU+. Everything as it should be. 99% I see no picture, from time to time it works, but very rarely.

Now I have tried many things. First of all I switched off enigma2 with "init 4". I see no difference.

I have tried different startup options. Since I am not deeply involved in Minisatip and I am actually only a user and not a professional, I do not have the deep knowledge of these things.

Which other things should I try to narrow it down.

as I asked several times already, there are some special things to consider at startup regarding unicableII/Jess.
So far you haven't said anything about this, but I found "-u" in the help, but I can't do anything with it, I don't know what belongs in it!

I'm attaching a picture of what the setting on the tvheadend looks like

Would it be better if I let you telnet to the receiver via Anydesk?
Attachments
minisat.PNG
minisat.PNG (18.97KiB)Viewed 2223 times

cata
Site Admin
Posts:609
Joined:Tue May 12, 2015 1:01 am

Re: minisatip vs VU+ Uno 4K and Tvheadend

Post by cata » Sun Apr 19, 2020 7:06 pm

if you run:
bash -x /etc/init.d/minisatip start
and you see something like:

Starting minisatip:+ start-stop-daemon -S -x /usr/bin/minisatip -p /var/run/minisatip.pid -- -R /usr/share/minisatip/html

it means you did not add the Unicable/Jess arguments (-u or -j parameters).
You should specify those according to your unicable/jess switch setup:

* -u --unicable unicable_string: defines the unicable adapters (A) and their slot (S), frequency (F) and optionally the PIN for the switch:
* The format is: A1:S1-F1[-PIN][,A2:S2-F2[-PIN][,...]]
eg: 2:0-1284[-1111]
* When * character is used before frequency, force 13V only for setup

Post Reply