CI+ protocol implementation in minisatip

Support forum for minisatip
solut
Posts: 14
Joined: Wed Jan 03, 2018 4:49 pm

Re: CI+ protocol implementation in minisatip

Post by solut » Fri Nov 01, 2019 8:04 pm

Hi Yuri,

I'm using two SatIP server with 4 tuners each, so I followed the minisatip documentation:
-e --enable-adapters list_of_enabled adapters: enable only specified adapters
eg: -e 0-2,5,7 (no spaces between parameters)
keep in mind that the first adapters are the local ones starting with 0 after that are the satip adapters if you have 3 local dvb cards 0-2 will be the local adapters, 3,4, ... will be the satip servers specified with argument -s
But I saw on the logs that u are right, the CIs are set after the SatIP devices...

SoI tried 8 and 9, switching the input of my CI adapter, but I didn't had any success.
Exactly the same bevaviour - the CAM get's initialized (CI+ is OK), but I get one time
found CW: 0
and then only
found CW: -1
What else can I try ?

Thanks, solut.

solut
Posts: 14
Joined: Wed Jan 03, 2018 4:49 pm

Re: CI+ protocol implementation in minisatip

Post by solut » Fri Nov 01, 2019 9:07 pm

It's working!
I deleted the bin files + bootid (?) and start minisatip with --ca-pin 8:xxxx (no ca assignment).

Thanks, solut.

sardonis
Posts: 13
Joined: Sat Jun 17, 2017 7:10 pm

Re: CI+ protocol implementation in minisatip

Post by sardonis » Wed Feb 12, 2020 9:29 am

I have problems on raspberry pi 4 with raspbian buster. I'm running a TechnoTrend TT-connect CT2-4650 CI USB tuner with default kernel media drivers. FTA channels are not a problem but encrypted channels don't work. Same tuner with same CI+ module is working on rpi3 with raspbian stretch without issues.

[12/02 09:12:32.354 AD0]: found CW: -1 for VIER HD PMT 4, pid 212, master 4, 0 ms ago, parity 1: not found
[12/02 09:12:32.406 AD0]: PID Continuity error (adapter 0): pid: 4201, Expected CC: A, Actual CC: 1, CC Before 9

On other occasions, I see a lot of error 524 in the logs. I'm suspecting a driver issue but I'm not sure. FTA picture is playing perfecly without any blocks or hickups.

[12/02 09:25:47.179 signal]: ad 0 ioctl fd 11 FE_READ_SIGNAL_STRENGTH failed, error 524 (Unknown error 524)
[12/02 09:25:47.179 signal]: ad 0 ioctl fd 11 FE_READ_SNR failed, error 524 (Unknown error 524)
[12/02 09:25:47.483 signal]: ad 0 ioctl fd 11, FE_READ_BER failed, error 524 (Unknown error 524)

Please find logs attached.
minisatip-logs.zip
(57.79 KiB) Downloaded 7 times

sardonis
Posts: 13
Joined: Sat Jun 17, 2017 7:10 pm

Re: CI+ protocol implementation in minisatip

Post by sardonis » Thu Feb 13, 2020 3:37 pm

I opened an issue on Github with more logs.

https://github.com/catalinii/minisatip/issues/713

Post Reply